Sunday, March 14, 2010

Adventures in Upgrading to Windows 7

Recently I purchased an OEM License of Windows 7 64 bit Home Premium from the wonderful online retailer Newegg. I have been running XP Professional for I don't know how long now, at least 5 years, probably more. I was on Service Pack 3 and things were actually quite stable. I am running the following hardware for reference purposes...

  • Asus AV8-XE Motherboard
  • AMD Athlon 64 X2 Dual Core CPU at 2200 MHZ
  • 4 Meg of System Memory
  • Ati Radeon 2900 Pro
  • VIA VT8251 High Def On Board Audio
  • WD740GD 74 Gig 10000 RPM Sata Drive C
  • ST3250823AS 250 Gig 7200 RPM Sata Drive D
  • DVR-111D Pioneer DVD-RW ATA

My first line of business was to get all of my data off of the existing drives. For this reason I purchased a DLink DNS-321 Network Attached Storage and threw a couple of Western Digital Green 1.5 TB drives into it. This journey will be a separate post but I wanted to note it here anyway as it was an important pre-step for this upgrade. Things to think about when you are migrating include

  • Photos
  • Music
  • Documents
  • Game Saves
  • Applications that save outside of My Documents
  • Outlook PST files
  • Favorites
  • Anything else you can think of

Basically what I did is just backed up everything I could think of to the NAS. It took a long time to do this over the network but it was worth it as I was sure that I could get something back if I needed it. The peace of mind is good to have and will save you once you wipe your drive for the operating system upgrade.

Ok, so we've got everything backed up now and are ready to get started. First things first, you have to go into your BIOS settings and make sure you can boot from your DVD drive. In my case I hit the DEL Key while the machine is coming up and then go into the boot settings. Move the boot priority up on the DVD drive (just make sure it is above the Hard Disk). Now exit and save your settings and if the Windows 7 DVD is in it will ask "Hit any Key to boot from DVD". Do so and a few moments later you'll see the cool new Windows 7 installation screen.

After getting through the initial screens I came to the screen which is always fun. I like to call it the blow away your hard drive screen. Here is where you can delete the partitions. Now, since I had backed everything up to the NAS I could confidently press the keys to delete my primary windows partition. Although even having this backup I still hesitated to do so, remember there is NO backing out once you've done this. Oh I'm sure someone will say you can use this tool or that tool to recover it even after deleting the partition but what a hassle that would be.

So you choose the drive you want Windows 7 installed on and the rest is pretty much automatic. There are a few questions regarding your keyboard type and time and date but soon you will see the fruits of your labor in the fancy new Windows 7 Desktop.  First things first, this is NOT windows XP, it's not Vista either.  This is a pretty new experience to me.  Sure you can get around, but things look weird at first.  The task bar for one look quite a bit different.  I'm sure there is a way to get it to look like the old one but I wanted all the new here so I'm embracing the new technology.  Aero is pretty cool too, if you don't know what that is basically it spruces up the entire desktop experience and makes everything behind what you're doing sorta visible through windows that are opaque.  There are plenty of other changes too including Gadgets which are essentially what Yahoo released a couple of years ago but they are cool to have built in.  I chose a clock, a cpu/memory meter and the Weather.  I put these on the 2nd monitor so they don't clutter things up and it really is nice to have the dashboard as I call it.  There are other cool gadgets too like an RSS feed reader and Internet Usage meter to name a couple.  I will continue to investigate these to see if any new ones come up that I want to try.

Alright so things are running but I hit the first snag immediately.  NO Sound.  So what's up with that.  Ok, so snag number two shows up pretty soon too, the machine won't boot unless I have the Windows 7 DVD in the drive, man that's a bummer, gotta fix that.  Finally I had installed the ATI catalyst drivers but the windows desktop is reporting a graphics card crash almost every 2-3 minutes.  Yeah, these are all bad, i'm starting to not feel too good about this upgrade now but let's roll on and see if we can fix some of these issues.

Turns out that there aren't any Audio drivers for Windows 7 for my onboard sound card.  The first thing I tried was an old Sound Blaster Audigy card but I couldn't even get it to work at all. I started poking around the forums and finally found a set of Vista 64 drivers that apparently work.  I installed them and do get sound but it seems a little weird at times, like it fades in an out to a degree.  Here is hoping that Soundmax will eventually release a Windows 7 native driver for this motherboard, but I'm happy for the moment at least.

For the Video card while using the 2900 Pro I actually went back to the included Windows 7 drivers.  Things were stable but not giving me the very best performance.  I purchased an ATI Radeon 4650 HD for a reasonable price and plugged it in.  It has a Gig of DDR3 memory on it and is a couple of years newer than the 2900 Pro so I had pretty good expectations from it.  The catalyst drivers so far are running well and it seems overall faster than what I so I'm happy.

Finally the boot issue.  Turns out that the Windows 7 installer decides where to put a 100mb partition pretty much on its own.  This partition contains the boot information and if you don't have this drive set up to be your boot partition in your bios then it will not boot unless you have the Windows 7 DVD in the drive.  In my case I just went into the BIOS and made sure that this drive was marked first in the boot order and all was well.

So, the Windows 7 upgrade didn't go exactly perfectly but you know, I'm glad I did it.  I certainly enjoy being in the 64 bit world now and being able to use all 4 gigabytes of my system memory.  I do notice some issues though, particularly around certain software not running at all like some of the old games that I have.  Battlefield 2 and Battlefield 2142 didn't run at all.  Outlook 7 seems to crash quite often and I've had a few crashes of Internet Explorer 64 bit which to be fair I had these in the old Windows XP also but I wanted more stability here.  I guess at the end of the day I'm now in the new world so things will get better with time.  I will update more as I get more experience.   Thanks for reading!

No comments:

Post a Comment

Please keep all comments relevant to the particular blog post. Try to keep the comments positive and please avoid flaming either me or other posters. I reserve the right to delete any posts that are not relevant but I promise not to be an overbearing moderator. Thanks!